Как сделать или в excel?

Функции ИЛИ в Excel

Добрый день уважаемый читатель!

В этой статье рассмотрим, еще одну логическую функцию MS Excel, функцию ИЛИ. Она являются очень хорошей логической функцией, которая в дополнение с другими функциями, например, ЕСЛИ, даст очень хороший результат. Стоит признать, что самостоятельное использование функцию ИЛИ, не принесет большой пользы. Как и функция И, функция ИЛИ эффективная будет только в тандеме с другими функциями формулы, в которую будет передаваться полученный результат.

Использование функции ИЛИ производится тогда, когда возникает необходимость проверки условий типа: Условие№1 ИЛИ Условие№2. Итог функции будет ИСТИНА в случае, когда все или хотя бы одно из указанных условий будет соответствовать правильному значению, результат ЛОЖЬ будет получен в случае, когда все аргументы функции не соответствуют заданному критерию.

Синтаксис этой логической функции также прост и неказист и выглядит следующим образом:

=ИЛИ(Логическое_значение№1;[логическое значение№2];. ), где:

  • Логическое_значение№1 – является обязательным аргументом, вычисление которого дает результат ЛОЖЬ или ИСТИНА;
  • [логическое значение№2] – является необязательным дополнительным проверяемым условием, также дающим результат вычисления ИСТИНА или ЛОЖЬ. Количество таких условий не должно превышать 255.

Примечания по работе с функцией ИЛИ.

Пример№1: Простое условия функции ИЛИ.

На небольшом примере логических комбинаций ИСТИНА и ЛОЖЬ рассмотрим получаемый результат при использовании функции: При использовании логических условий в натуральных показателях будет получен следующий результат: Пример№2: Совместная работа с функцией ЕСЛИ.

Поскольку функцию ИЛИ также наградили ограниченным использованием, то наиболее рациональным будет ее использовать вместе с другой функцией, такой как ЕСЛИ. Так как функция возвращает только значения ИСТИНА или ЛОЖЬ, ее можна использовать как критерий логического отбора:

=ЕСЛИ(ИЛИ(B13>10;C13>10);»Лимит превышен»;»В границах лимита»)

То есть когда в любой из ячеек содержится значение больше 10, то будет выводиться значение «Лимит превышен», а если во всех ячейках хранится значение менее 10, то получаем «В границах лимита». Пример№3: Проверка с помощью массива похожих условий.

Представим, что возникла необходимость сравнить определённое контрольное значение $C$24 (закреплённая абсолютная ссылка) с тестовым диапазоном A19:A22. В случае, когда в данном диапазоне будет обнаружено контрольное значение, формула вернет значение ИСТИНА.

Для получения такого результата нам понадобится формула: =ИЛИ(A19:A22=$C$24), которую введем в ячейку как формулу массива, с помощью комбинации Ctrl+Shift+Enter вместо простого нажатия Enter. Пример№4: Расчёт комиссионных надбавок по результатам работы.

Еще один пример тандемной связки функций ИЛИ с функцией ЕСЛИ. В примере формула должна определить выполнены ли условия начисления комиссионных выплат и если да, то, в каком размере их начислять:

=ЕСЛИ(ИЛИ(B35>=$C$29;C35>=$C$30);B35*$C$31;0). Я очень надеюсь, что смог более подробно и понятно описать работу логической функции ИЛИ в Excel. Что позволит вам увеличит эффективность вашей работы и если это случилось, жду ваши лайки, а если у вас возникли вопросы, пишите комментарии.

С другими функциями электронных таблиц вы можете узнать в «Справочнике функций».

До новых встреч на страницах TopExcel.ru!

Деньги нужны даже для того, чтобы без них обходиться.
Оноре де Бальзак

Использование ЕСЛИ с функциями И, ИЛИ и НЕ

Функция ЕСЛИ позволяет выполнять логические сравнения значений и ожидаемых результатов. Она проверяет условие и в зависимости от его истинности возвращает результат.

=ЕСЛИ(это истинно, то сделать это, в противном случае сделать что-то еще)

Но что делать, если необходимо проверить несколько условий, где, допустим, все условия должны иметь значение ИСТИНА или ЛОЖЬ (И), только одно условие должно иметь такое значение (ИЛИ) или вы хотите убедиться, что данные НЕ соответствуют условию? Эти три функции можно использовать самостоятельно, но они намного чаще встречаются в сочетании с функцией ЕСЛИ.

Используйте функцию ЕСЛИ вместе с функциями И, ИЛИ и НЕ, чтобы оценивать несколько условий.

ЕСЛИ(И()): ЕСЛИ(И(лог_выражение1; [лог_выражение2]; …), значение_если_истина; [значение_если_ложь]))

ЕСЛИ(ИЛИ()): ЕСЛИ(ИЛИ(лог_выражение1; [лог_выражение2]; …), значение_если_истина; [значение_если_ложь]))

ЕСЛИ(НЕ()): ЕСЛИ(НЕ(лог_выражение1), значение_если_истина; [значение_если_ложь]))

Условие, которое нужно проверить.

Значение, которое должно возвращаться, если лог_выражение имеет значение ИСТИНА.

Значение, которое должно возвращаться, если лог_выражение имеет значение ЛОЖЬ.

Общие сведения об использовании этих функций по отдельности см. в следующих статьях: И, ИЛИ, НЕ. При сочетании с оператором ЕСЛИ они расшифровываются следующим образом:

И: =ЕСЛИ(И(условие; другое условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

ИЛИ: =ЕСЛИ(ИЛИ(условие; другое условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

НЕ: =ЕСЛИ(НЕ(условие); значение, если ИСТИНА; значение, если ЛОЖЬ)

Ниже приведены примеры распространенных случаев использования вложенных операторов ЕСЛИ(И()), ЕСЛИ(ИЛИ()) и ЕСЛИ(НЕ()). Функции И и ИЛИ поддерживают до 255 отдельных условий, но рекомендуется использовать только несколько условий, так как формулы с большой степенью вложенности сложно создавать, тестировать и изменять. У функции НЕ может быть только одно условие.

Ниже приведены формулы с расшифровкой их логики.

=ЕСЛИ(И(A2>0;B2 0;B4 50);ИСТИНА;ЛОЖЬ)

Если A6 (25) НЕ больше 50, возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ. В этом случае значение не больше чем 50, поэтому формула возвращает значение ИСТИНА.

Если значение A7 («синий») НЕ равно «красный», возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ.

Обратите внимание, что во всех примерах есть закрывающая скобка после условий. Аргументы ИСТИНА и ЛОЖЬ относятся ко внешнему оператору ЕСЛИ. Кроме того, вы можете использовать текстовые или числовые значения вместо значений ИСТИНА и ЛОЖЬ, которые возвращаются в примерах.

Вот несколько примеров использования операторов И, ИЛИ и НЕ для оценки дат.

Ниже приведены формулы с расшифровкой их логики.

Если A2 больше B2, возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ. В этом случае 12.03.14 больше чем 01.01.14, поэтому формула возвращает значение ИСТИНА.

=ЕСЛИ(И(A3>B2;A3 B2;A4 B2);ИСТИНА;ЛОЖЬ)

Если A5 не больше B2, возвращается значение ИСТИНА, в противном случае возвращается значение ЛОЖЬ. В этом случае A5 больше B2, поэтому формула возвращает значение ЛОЖЬ.

Использование операторов И, ИЛИ и НЕ с условным форматированием

Вы также можете использовать операторы И, ИЛИ и НЕ в формулах условного форматирования. При этом вы можете опустить функцию ЕСЛИ.

На вкладке Главная выберите Условное форматирование > Создать правило. Затем выберите параметр Использовать формулу для определения форматируемых ячеек, введите формулу и примените формат.

«Изменить правило» с параметром «Формула»» />

Вот как будут выглядеть формулы для примеров с датами:

Функции ИЛИ в Excel

Добрый день уважаемый читатель!

В этой статье рассмотрим, еще одну логическую функцию MS Excel, функцию ИЛИ. Она являются очень хорошей логической функцией, которая в дополнение с другими функциями, например, ЕСЛИ, даст очень хороший результат. Стоит признать, что самостоятельное использование функцию ИЛИ, не принесет большой пользы. Как и функция И, функция ИЛИ эффективная будет только в тандеме с другими функциями формулы, в которую будет передаваться полученный результат.

Использование функции ИЛИ производится тогда, когда возникает необходимость проверки условий типа: Условие№1 ИЛИ Условие№2. Итог функции будет ИСТИНА в случае, когда все или хотя бы одно из указанных условий будет соответствовать правильному значению, результат ЛОЖЬ будет получен в случае, когда все аргументы функции не соответствуют заданному критерию.

Синтаксис этой логической функции также прост и неказист и выглядит следующим образом:

=ИЛИ(Логическое_значение№1;[логическое значение№2];. ), где:

  • Логическое_значение№1 – является обязательным аргументом, вычисление которого дает результат ЛОЖЬ или ИСТИНА;
  • [логическое значение№2] – является необязательным дополнительным проверяемым условием, также дающим результат вычисления ИСТИНА или ЛОЖЬ. Количество таких условий не должно превышать 255.

Примечания по работе с функцией ИЛИ.

Пример№1: Простое условия функции ИЛИ.

На небольшом примере логических комбинаций ИСТИНА и ЛОЖЬ рассмотрим получаемый результат при использовании функции: При использовании логических условий в натуральных показателях будет получен следующий результат: Пример№2: Совместная работа с функцией ЕСЛИ.

Поскольку функцию ИЛИ также наградили ограниченным использованием, то наиболее рациональным будет ее использовать вместе с другой функцией, такой как ЕСЛИ. Так как функция возвращает только значения ИСТИНА или ЛОЖЬ, ее можна использовать как критерий логического отбора:

=ЕСЛИ(ИЛИ(B13>10;C13>10);»Лимит превышен»;»В границах лимита»)

То есть когда в любой из ячеек содержится значение больше 10, то будет выводиться значение «Лимит превышен», а если во всех ячейках хранится значение менее 10, то получаем «В границах лимита». Пример№3: Проверка с помощью массива похожих условий.

Представим, что возникла необходимость сравнить определённое контрольное значение $C$24 (закреплённая абсолютная ссылка) с тестовым диапазоном A19:A22. В случае, когда в данном диапазоне будет обнаружено контрольное значение, формула вернет значение ИСТИНА.

Для получения такого результата нам понадобится формула: =ИЛИ(A19:A22=$C$24), которую введем в ячейку как формулу массива, с помощью комбинации Ctrl+Shift+Enter вместо простого нажатия Enter. Пример№4: Расчёт комиссионных надбавок по результатам работы.

Еще один пример тандемной связки функций ИЛИ с функцией ЕСЛИ. В примере формула должна определить выполнены ли условия начисления комиссионных выплат и если да, то, в каком размере их начислять:

=ЕСЛИ(ИЛИ(B35>=$C$29;C35>=$C$30);B35*$C$31;0). Я очень надеюсь, что смог более подробно и понятно описать работу логической функции ИЛИ в Excel. Что позволит вам увеличит эффективность вашей работы и если это случилось, жду ваши лайки, а если у вас возникли вопросы, пишите комментарии.

С другими функциями электронных таблиц вы можете узнать в «Справочнике функций».

До новых встреч на страницах TopExcel.ru!

Деньги нужны даже для того, чтобы без них обходиться.
Оноре де Бальзак

Использование оператора «ЕСЛИ» в Microsoft Excel

Среди многих функций, с которыми работает Microsoft Excel, следует выделить функцию «ЕСЛИ». Это один из тех операторов, к которым пользователи прибегают чаще всего при выполнении задач в программе. Давайте разберемся, что представляет собой эта функция и как с ней работать.

Общее определение и задачи

«ЕСЛИ» является стандартной функцией программы Microsoft Excel. В ее задачи входит проверка выполнения конкретного условия. Когда условие выполнено (истина), то в ячейку, где использована данная функция, возвращается одно значение, а если не выполнено (ложь) – другое.

Синтаксис этой функции выглядит следующим образом: «ЕСЛИ(логическое выражение; [функция если истина]; [функция если ложь])» .

Пример использования «ЕСЛИ»

Теперь давайте рассмотрим конкретные примеры, где используется формула с оператором «ЕСЛИ».

  1. Имеем таблицу заработной платы. Всем женщинам положена премия к 8 марту в 1000 рублей. В таблице есть колонка, где указан пол сотрудников. Таким образом, нам нужно вычислить женщин из предоставленного списка и в соответствующих строках колонки «Премия к 8 марта» вписать по «1000». В то же время, если пол не будет соответствовать женскому, значение таких строк должно соответствовать «0». Функция примет такой вид: «ЕСЛИ(B6=»жен.»; «1000»; «0»)» . То есть когда результатом проверки будет «истина» (если окажется, что строку данных занимает женщина с параметром «жен.»), то выполнится первое условие — «1000», а если «ложь» (любое другое значение, кроме «жен.»), то соответственно, последнее — «0».
  2. Вписываем это выражение в самую верхнюю ячейку, где должен выводиться результат. Перед выражением ставим знак «=».

Так мы получили таблицу со столбцом, заполненным при помощи функции «ЕСЛИ».

Пример функции с несколькими условиями

В функцию «ЕСЛИ» можно также вводить несколько условий. В этой ситуации применяется вложение одного оператора «ЕСЛИ» в другой. При выполнении условия в ячейке отображается заданный результат, если же условие не выполнено, то выводимый результат зависит уже от второго оператора.

  1. Для примера возьмем все ту же таблицу с выплатами премии к 8 марта. Но на этот раз, согласно условиям, размер премии зависит от категории работника. Женщины, имеющие статус основного персонала, получают бонус по 1000 рублей, а вспомогательный персонал получает только 500 рублей. Естественно, что мужчинам этот вид выплат вообще не положен независимо от категории.
  2. Первым условием является то, что если сотрудник — мужчина, то величина получаемой премии равна нулю. Если же данное значение ложно, и сотрудник не мужчина (т.е. женщина), то начинается проверка второго условия. Если женщина относится к основному персоналу, в ячейку будет выводиться значение «1000», а в обратном случае – «500». В виде формулы это будет выглядеть следующим образом: «=ЕСЛИ(B6=»муж.»;»0″; ЕСЛИ(C6=»Основной персонал»; «1000»;»500″))» .
  3. Вставляем это выражение в самую верхнюю ячейку столбца «Премия к 8 марта».

Как и в прошлый раз, «протягиваем» формулу вниз.

Пример с выполнением двух условий одновременно

В функции «ЕСЛИ» можно также использовать оператор «И», который позволяет считать истинной только выполнение двух или нескольких условий одновременно.

  1. Например, в нашей ситуации премия к 8 марта в размере 1000 рублей выдается только женщинам, которые являются основным персоналом, а мужчины и представительницы женского пола, числящиеся вспомогательным персоналом, не получают ничего. Таким образом, чтобы значение в ячейках колонки «Премия к 8 марта» было 1000, нужно соблюдение двух условий: пол – женский, категория персонала – основной персонал. Во всех остальных случаях значение в этих ячейках будет рано нулю. Это записывается следующей формулой: «=ЕСЛИ(И(B6=»жен.»; C6=»Основной персонал»); «1000»; «0»)» . Вставляем ее в ячейку.

Копируем значение формулы на ячейки, расположенные ниже, аналогично продемонстрированным выше способам.

Пример использования оператора «ИЛИ»

В функции «ЕСЛИ» также может использоваться оператор «ИЛИ». Он подразумевает, что значение является истинным, если выполнено хотя бы одно из нескольких условий.

    Итак, предположим, что премия к 8 марта в 1000 рублей положена только женщинам, которые входят в число основного персонала. В этом случае, если работник — мужчина или относится к вспомогательному персоналу, то величина его премии будет равна нулю, а иначе – 1000 рублей. В виде формулы это выглядит так: «=ЕСЛИ(ИЛИ(B6=»муж.»; C6=»Вспомогательный персонал»); «0»; «1000»)» . Записываем ее в соответствующую ячейку таблицы.

«Протягиваем» результаты вниз.

Как видим, функция «ЕСЛИ» может оказаться для пользователя хорошим помощником при работе с данными в Microsoft Excel. Она позволяет отобразить результаты, соответствующие определенным условиям.

Отблагодарите автора, поделитесь статьей в социальных сетях.

Читать еще:  Как сделать чтобы в таблице excel не скрывались верхний столбец?
Ссылка на основную публикацию
Adblock
detector