Как сделать счетесли в excel?

Функция СЧЕТЕСЛИ в Excel

В этой статье мы сосредоточимся на функции СЧЕТЕСЛИ в Excel, которая предназначена для подсчета ячеек с указанным вами условием. Во-первых, мы кратко рассмотрим синтаксис и общее использование, а затем приведем ряд примеров функции СЧЕТЕСЛИ.

По сути, функция СЧЕТЕСЛИ на английском COUNTIF, идентична во всех версиях Excel, поэтому вы можете использовать примеры из этого руководства в Excel 2016, 2013, 2010 и 2007.

Синтаксис и использование функции СЧЕТЕСЛИ в Excel

Функция СЧЕТЕСЛИ в Excel используется для подсчета ячеек в пределах заданного диапазона, которые соответствуют определенному критерию или условию.

Например, вы можете использовать функцию СЧЕТЕСЛИ, чтобы узнать, сколько ячеек на вашем листе содержит число больше или меньше указанного вами числа. Другое типичное использование функции СЧЕТЕСЛИ в Excel — подсчет ячеек с определенным словом или началом с конкретной буквы (букв).

Синтаксис функции СЧЕТЕСЛИ очень прост:

Как видите, есть только 2 аргумента функции СЧЕТЕСЛИ, оба из которых обязательны:

  • диапазон – определяет одну или несколько ячеек для подсчета. Вы помещаете диапазон в формулу, как обычно, в Excel, например. A1:A20.
  • критерии – определяет условие, которое сообщает функции, которую подсчитывают ячейки. Это может быть число, текстовая строка, ссылка на ячейку или выражение (например, «10», A2, «>=10»).

Вот простейший пример функции СЧЕТЕСЛИ в Excel. Формула =СЧЁТЕСЛИ(C2:C7;»Иванов Иван») подсчитывает, сколько заявок поступало от Иванова Ивана:

Функция СЧЕТЕСЛИ в Excel – Пример использования функции СЧЕТЕСЛИ в Excel

Примечание : Критерий нечувствителен к регистру, что означает, что если вы наберете «иванов иван» в качестве критерия в приведенной выше формуле СЧЕТЕСЛИ, это приведет к такому же результату.

Функция СЧЕТЕСЛИ в Excel – примеры

Синтаксис функции СЧЕТЕСЛИ очень прост, однако он допускает множество возможных вариантов критериев, включая подстановочные знаки, значения других ячеек и даже другие функции Excel.

Функция СЧЕТЕСЛИ в Excel для текста и чисел (точное совпадение)

Выше мы рассмотрели пример функции СЧЕТЕСЛИ, которая подсчитывает текстовые значения, соответствующие определенному критерию.

Вместо ввода текста вы можете использовать ссылку на любую ячейку , содержащую это слово или слова, и получить абсолютно одинаковые результаты, например: =СЧЕТЕСЛИ(С1:С7; С2).

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ со ссылкой на ячейку

Аналогичные формулы СЧЕТЕСЛИ работают для чисел , также как для текстовых значений.

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ для чисел

На изображении выше формула =СЧЁТЕСЛИ(B2:B7;10) учитывает ячейки с количеством 10 в столбце D.

Чтобы подсчитать ячейки со значениями больше, меньше или равными указанному вами числу, вы просто добавляете соответствующий логический оператор к критериям.

Обратите внимание, что в функции СЧЕТЕСЛИ оператор с числом всегда заключен в кавычки, например, =СЧЕТЕСЛИ(B2:B7; «>=10»).

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ для чисел с логическим оператором

Функция СЧЕТЕСЛИ с подстановочными знаками (частичное совпадение)

Если данные Excel содержат несколько вариантов ключевых слов, которые вы хотите подсчитать, вы можете использовать подстановочный знак в функции СЧЕТЕСЛИ для подсчета всех ячеек, содержащих определенное слово, фразу или буквы, как часть содержимого ячейки.

Предположим, у вас есть список цветов, и вы хотите узнать количество цветов, в названии которых содержится слово «синий». Поскольку эти цвета можно написать несколькими разными способами, мы вводим «*синий*» в качестве критериев поиска =СЧЕТЕСЛИ(B2:B8;»*синий*»).

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ с частичным совпадением

Звездочка (*) используется в функции СЧЕТЕСЛИ для поиска ячеек с любой последовательностью ведущих и конечных символов, как показано в приведенном выше примере. Если вам нужно сопоставить какой-либо один символ, введите вместо него знак вопроса (?) , например, =СЧЁТЕСЛИ(A2:A7;»ст?л»).

Читать еще:  Как сделать тест по информатике в excel с гиперссылками?

Функция СЧЕТЕСЛИ в Excel – Пример функции СЧЕТЕСЛИ с подстановочным знаком

В данном случае функция СЧЕТЕСЛИ вернет значение 2, так как найдет «стол» и «стул».

Функция СЧЕТЕСЛИ в Excel и примеры ее использования

Функция СЧЕТЕСЛИ входит в группу статистических функций. Позволяет найти число ячеек по определенному критерию. Работает с числовыми и текстовыми значениями, датами.

Синтаксис и особенности функции

Сначала рассмотрим аргументы функции:

  • Диапазон – группа значений для анализа и подсчета (обязательный).
  • Критерий – условие, по которому нужно подсчитать ячейки (обязательный).

В диапазоне ячеек могут находиться текстовые, числовые значения, даты, массивы, ссылки на числа. Пустые ячейки функция игнорирует.

В качестве критерия может быть ссылка, число, текстовая строка, выражение. Функция СЧЕТЕСЛИ работает только с одним условием (по умолчанию). Но можно ее «заставить» проанализировать 2 критерия одновременно.

Рекомендации для правильной работы функции:

  • Если функция СЧЕТЕСЛИ ссылается на диапазон в другой книге, то необходимо, чтобы эта книга была открыта.
  • Аргумент «Критерий» нужно заключать в кавычки (кроме ссылок).
  • Функция не учитывает регистр текстовых значений.
  • При формулировании условия подсчета можно использовать подстановочные знаки. «?» — любой символ. «*» — любая последовательность символов. Чтобы формула искала непосредственно эти знаки, ставим перед ними знак тильды (

).

  • Для нормального функционирования формулы в ячейках с текстовыми значениями не должно пробелов или непечатаемых знаков.
  • 

    Функция СЧЕТЕСЛИ в Excel: примеры

    Посчитаем числовые значения в одном диапазоне. Условие подсчета – один критерий.

    У нас есть такая таблица:

    Посчитаем количество ячеек с числами больше 100. Формула: =СЧЁТЕСЛИ(B1:B11;»>100″). Диапазон – В1:В11. Критерий подсчета – «>100». Результат:

    Если условие подсчета внести в отдельную ячейку, можно в качестве критерия использовать ссылку:

    Посчитаем текстовые значения в одном диапазоне. Условие поиска – один критерий.

    Формула: =СЧЁТЕСЛИ(A1:A11;»табуреты»). Или:

    Во втором случае в качестве критерия использовали ссылку на ячейку.

    Формула с применением знака подстановки: =СЧЁТЕСЛИ(A1:A11;»таб*»).

    Для расчета количества значений, оканчивающихся на «и», в которых содержится любое число знаков: =СЧЁТЕСЛИ(A1:A11;»*и»). Получаем:

    Формула посчитала «кровати» и «банкетки».

    Используем в функции СЧЕТЕСЛИ условие поиска «не равно».

    Формула: =СЧЁТЕСЛИ(A1:A11;»<>«&»стулья»). Оператор «<>» означает «не равно». Знак амперсанда (&) объединяет данный оператор и значение «стулья».

    При применении ссылки формула будет выглядеть так:

    Часто требуется выполнять функцию СЧЕТЕСЛИ в Excel по двум критериям. Таким способом можно существенно расширить ее возможности. Рассмотрим специальные случаи применения СЧЕТЕСЛИ в Excel и примеры с двумя условиями.

    1. Посчитаем, сколько ячеек содержат текст «столы» и «стулья». Формула: =СЧЁТЕСЛИ(A1:A11;»столы»)+СЧЁТЕСЛИ(A1:A11;»стулья»). Для указания нескольких условий используется несколько выражений СЧЕТЕСЛИ. Они объединены между собой оператором «+».
    2. Условия – ссылки на ячейки. Формула: =СЧЁТЕСЛИ(A1:A11;A1)+СЧЁТЕСЛИ(A1:A11;A2). Текст «столы» функция ищет в ячейке А1. Текст «стулья» — на базе критерия в ячейке А2.
    3. Посчитаем число ячеек в диапазоне В1:В11 со значением большим или равным 100 и меньшим или равным 200. Формула: =СЧЁТЕСЛИ(B1:B11;»>=100″)-СЧЁТЕСЛИ(B1:B11;»>200″).
    4. Применим в формуле СЧЕТЕСЛИ несколько диапазонов. Это возможно, если диапазоны являются смежными. Формула: =СЧЁТЕСЛИ(A1:B11;»>=100″)-СЧЁТЕСЛИ(A1:B11;»>200″). Ищет значения по двум критериям сразу в двух столбцах. Если диапазоны несмежные, то применяется функция СЧЕТЕСЛИМН.
    5. Когда в качестве критерия указывается ссылка на диапазон ячеек с условиями, функция возвращает массив. Для ввода формулы нужно выделить такое количество ячеек, как в диапазоне с критериями. После введения аргументов нажать одновременно сочетание клавиш Shift + Ctrl + Enter. Excel распознает формулу массива.

    СЧЕТЕСЛИ с двумя условиями в Excel очень часто используется для автоматизированной и эффективной работы с данными. Поэтому продвинутому пользователю настоятельно рекомендуется внимательно изучить все приведенные выше примеры.

    ПРОМЕЖУТОЧНЫЕ.ИТОГИ и СЧЕТЕСЛИ

    Посчитаем количество реализованных товаров по группам.

    1. Сначала отсортируем таблицу так, чтобы одинаковые значения оказались рядом.
    2. Первый аргумент формулы «ПРОМЕЖУТОЧНЫЕ.ИТОГИ» — «Номер функции». Это числа от 1 до 11, указывающие статистическую функцию для расчета промежуточного результата. Подсчет количества ячеек осуществляется под цифрой «2» (функция «СЧЕТ»).

    Формула нашла количество значений для группы «Стулья». При большом числе строк (больше тысячи) подобное сочетание функций может оказаться полезным.

    Функция СЧЕТЕСЛИ в Эксель

    Автор: rf-webmaestro · Опубликовано 26.02.2018 · Обновлено 08.02.2019

    Программа Excel предоставляет широкий функционал по созданию баз данных, таблиц и списков. Также в ней встроены специальные инструменты для ведения учета и подсчета статистических данных. Функция СЧЕТЕСЛИ в Excel как раз относится к таким возможностям. Разберемся, как работать с данным инструментом на нескольких примерах.

    СЧЕТЕСЛИ можно отнести к группе критериев. Это вычисления, которые можно получить по заранее заданным условиям. К подобным инструментам также относятся СЧЕТЕСЛИМН, СУММЕСЛИ, СУММЕСЛИМН.

    Оператор СЧЕТЕСЛИ в «Эксель» применяется для поиска значений, удовлетворяющих заданным условиям. Рассмотрим детально синтаксис. Функция записывается в ячейке в виде =СЧЕТЕСЛИ(диапазон;критерий)

    Как видите, формула оператора довольно простая – достаточно запомнить, за что отвечает каждый из параметров:

    • диапазон – это строка, столбец или массив элементов, из которых осуществляется выборка по критериям;
    • критерий – четко установленное условие, которому должны отвечать все найденные значения выбранного массива.

    В качестве критерия могут использоваться текст на русском или английском, числа, знаки , даты, куски слов и т. д.

    Функция будет исправно работать, если команда написано верно, выбранный диапазон не пустой, а условие не противоречит содержанию массива. СЧЕТЕСЛИ и подобные статистические операторы активно применяются в складском учете или аналитических таблицах.

    Как пользоваться?

    Если вы хорошо знакомы с синтаксисом и уже несколько раз использовали данную возможность в Excel, то можете спокойно вписывать команду вручную в необходимой вам ячейке:

    Также вы можете находиться в поле для введения функций, которое расположено над основным окном с таблицей. При вводе текста туда, на экране будут появляться подсказки с возможными вариантами команд.

    Последний способ – открыть окно с функциями. Это верхняя шапка программы. Вы можете сделать следующим образом:

    1. Зайти во вкладку «Формулы» и нажать на кнопку «Вставить функцию».

    1. После этого воспользоваться поиском (1) или выбрать группу «Статистические» и найти нужный оператор в списке (2).

    1. Снова откройте раздел «Формулы» и нажмите на кнопку «Другие функции».

    1. В открывшемся списке выберите «Статистические» и найдите нужный инструмент в списке.

    Теперь переходим к тому, как работать с данным инструментом в рамках различных таблиц и массивов. Разберемся в этом на примере.

    Как посчитать значения с одним критерием

    Начнем с простых операций – поиск определенных слов/чисел по одному заданному условию. Считать будем на примере простой таблицы:

    Необходимо найти, сколько предметов мебели из данного списка превышает количество 100 единиц. Для этого делаем следующее:

    1. Встаем в нужную ячейку и нажимаем отмеченную на скриншоте кнопку.

    1. Находим СЧЕТЕСЛИ (можно написать в поиске для удобства).

    1. Теперь задаем диапазон. Для этого мышкой выделяем промежуток с количеством единиц мебели.

    1. Задаем критерий. Вписываем то значение, которое необходимо найти в выбранном массиве.

    1. Нажмите кнопку «ОК» для начала вычисления. В выбранной клетке появится результат. В примере мало строк, поэтому его можно проверить вручную и убедиться в правильности выполнения.

    Считаем текстовые значения

    Теперь необходимо сделать так, чтобы оператор нашел количество позиций с торшерами в данной таблице. Разберемся, как вписывать данные вручную. Для этого необходимо:

    1. Снова выберите ячейку, в которой должен появиться конечный результат, и перейдите в верхнюю строку.

    1. Вписываем команду «=СЧЕТЕСЛИ» и открываем скобку.

    1. Выделяем диапазон столбца с названиями позиций.

    1. Теперь ставим знак «;» и пишем «торшеры». Между диапазоном и критерием пробел не ставится.

    1. Закрываем скобку и жмем Enter для выполнения операции. В выбранной клетке появится необходимое решение. Поскольку значений, опять же, не так много, результат можно проверить вручную.

    Поиск по части слова или букве

    Инструмент позволяет подсчитать количество клеток, которые начинаются или заканчиваются на определенную букву. Также поиск можно осуществить по части слова. Рассмотрим следующий пример:

    1. Найдем количество позиций, которые начинаются на букву «Т». Для этого вновь выбираем отдельную ячейку и начинаем писать «СЧЕТЕСЛИ».

    1. Выбираем диапазон с названиями продукции.

    1. Далее вписываем букву «Т» и ставим знак «*» (звездочка). Если поставить его после вписанного знака, то буква будет считаться начальной. Если поставить звездочку перед буквой, то оператор проведет поиск по последним символам слов.

    1. Жмем Enter и смотрим на результат.

    Поиск исключений

    Теперь воспользуемся другой возможностью – найдем значения, которые не соответствуют заданному критерию. Выполним действия на примере все той же таблицы:

    1. Найдем количество позиций, в которых нет слова «столы». Для этого в ячейке необходимо ввести уже знакомую формулу и выделить список названий.

    1. Через точку с запятой в кавычках вписать «<>столы*». Звездочка необходима для того, чтобы в выборку входила ячейка «Столы1».

    1. В клетке появится результат вычислений.

    Поиск по нескольким критериям

    Зачастую пользователям требуется провести поиск по нескольким названиям или условиям сразу. В этом случае вы можете объединить несколько формул в одну с помощью знака «+». Посчитаем, сколько позиций столов в количестве более 140 встречается в таблице:

    1. Вводим синтаксис в необходимую клетку и выделяем диапазон. Вписываем «столы» и закрываем оператор.

    1. Далее ставим знак «+» и пишем новую формулу, в которой используем те же значения списка, но вместо критерия пишем «>140».

    1. Смотрим результат и сверяем.

    Несколько полезных советов:

    • если ваша формула отсылается на ячейки из другой базы данных, то в момент вычисления она должна быть открыта в Excel;
    • при поиске текста не учитывается регистр символов;
    • чтобы программа искала сами знаки >,

    Подсчет ячеек в Excel, используя функции СЧЕТ и СЧЕТЕСЛИ

    Очень часто при работе в Excel требуется подсчитать количество ячеек на рабочем листе. Это могут быть пустые или заполненные ячейки, содержащие только числовые значения, а в некоторых случаях, их содержимое должно отвечать определенным критериям. В этом уроке мы подробно разберем две основные функции Excel для подсчета данных – СЧЕТ и СЧЕТЕСЛИ, а также познакомимся с менее популярными – СЧЕТЗ, СЧИТАТЬПУСТОТЫ и СЧЕТЕСЛИМН.

    Статистическая функция СЧЕТ подсчитывает количество ячеек в списке аргументов, которые содержат только числовые значения. Например, на рисунке ниже мы подсчитали количество ячеек в диапазоне, который полностью состоит из чисел:

    В следующем примере в двух ячейках диапазона содержится текст. Как видите, функция СЧЕТ их игнорирует.

    А вот ячейки, содержащие значения даты и времени, учитываются:

    Функция СЧЕТ может подсчитывать количество ячеек сразу в нескольких несмежных диапазонах:

    Если необходимо подсчитать количество непустых ячеек в диапазоне, то можно воспользоваться статистической функцией СЧЕТЗ. Непустыми считаются ячейки, содержащие текст, числовые значения, дату, время, а также логические значения ИСТИНА или ЛОЖЬ.

    Решить обратную задачу, т.е. подсчитать количество пустых ячеек в Excel, Вы сможете, применив функцию СЧИТАТЬПУСТОТЫ:

    Статистическая функция СЧЕТЕСЛИ позволяет производить подсчет ячеек рабочего листа Excel с применением различного вида условий. Например, приведенная ниже формула возвращает количество ячеек, содержащих отрицательные значения:

    Следующая формула возвращает количество ячеек, значение которых больше содержимого ячейки А4.

    СЧЕТЕСЛИ позволяет подсчитывать ячейки, содержащие текстовые значения. Например, следующая формула возвращает количество ячеек со словом “текст”, причем регистр не имеет значения.

    Логическое условие функции СЧЕТЕСЛИ может содержать групповые символы: * (звездочку) и ? (вопросительный знак). Звездочка обозначает любое количество произвольных символов, а вопросительный знак – один произвольный символ.

    Например, чтобы подсчитать количество ячеек, содержащих текст, который начинается с буквы Н (без учета регистра), можно воспользоваться следующей формулой:

    Если необходимо подсчитать количество ячеек, которые содержат ровно четыре символа, то используйте эту формулу:

    Функция СЧЕТЕСЛИ позволяет использовать в качестве условия даже формулы. К примеру, чтобы посчитать количество ячеек, значения в которых больше среднего значения, можно воспользоваться следующей формулой:

    Если одного условия Вам будет недостаточно, Вы всегда можете воспользоваться статистической функцией СЧЕТЕСЛИМН. Данная функция позволяет подсчитывать ячейки в Excel, которые удовлетворяют сразу двум и более условиям.

    К примеру, следующая формула подсчитывает ячейки, значения которых больше нуля, но меньше 50:

    Функция СЧЕТЕСЛИМН позволяет подсчитывать ячейки, используя условие И. Если же требуется подсчитать количество с условием ИЛИ, необходимо задействовать несколько функций СЧЕТЕСЛИ. Например, следующая формула подсчитывает ячейки, значения в которых начинаются с буквы А или с буквы К:

    Функции Excel для подсчета данных очень полезны и могут пригодиться практически в любой ситуации. Надеюсь, что данный урок открыл для Вас все тайны функций СЧЕТ и СЧЕТЕСЛИ, а также их ближайших соратников – СЧЕТЗ, СЧИТАТЬПУСТОТЫ и СЧЕТЕСЛИМН. Возвращайтесь к нам почаще. Всего Вам доброго и успехов в изучении Excel.

    Ссылка на основную публикацию
    Adblock
    detector