Как сделать таблицу истинности в excel?

Использование MS Excel при изучении математической логики

В настоящее время применение информационных технологий становится неотъемлемой частью образовательного процесса. Компьютер наиболее полно удовлетворяет дидактическим требованиям и позволяет адаптировать процесс обучения к индивидуальным особенностям учащихся.

Компьютерные технологии активно внедряются в процесс обучения и диагностики, позволяют упростить процесс отработки навыков и умений и оценки знаний учащихся.

В данной работе рассматривается применение табличного процессора MS Excel при изучении основ логики.

Существует множество задач, в которых исходные и результатные данные должны быть представлены в табличной форме. Электронные таблицы представляют собой удобный инструмент для автоматизации таких вычислений. Решения многих вычислительных задач на ЭВМ, которые раньше можно было осуществить только путем программирования, стало возможно реализовать. Использование математических формул в электронных таблицах позволяет представить взаимосвязь между различными параметрами некоторой реальной системы. Основное свойство электронных таблиц – мгновенный пересчет формул при изменении значений входящих в них операндов. Благодаря этому свойству, таблица представляет собой удобный инструмент для организации численного эксперимента:

  • подбор параметров,
  • прогноз поведения моделируемой системы,
  • анализ зависимостей,
  • планирование.

В электронных таблицах предусмотрен также графический режим работы, который дает возможность графического представления (в виде графиков, диаграмм) числовой информации, содержащейся в таблице.

В процессе изучения алгебры логики учащиеся знакомятся с такими понятиями как: высказывание, таблицы истинности, логические функции и логические операции. Алгебра логики является разделом математической логики, в которой изучаются методы доказательства истинности (1) или ложности (0) сложных логических конструкций, составленных из простых высказываний, на основе истинности или ложности последних. Для закрепления полученных знаний возможно использование табличного процессора MS Excel и его функций.

Для реализации функций булевой алгебры используются логические функции: ЕСЛИ, И, ИЛИ, НЕ, ИСТИНА и ЛОЖЬ. При работе с функциями в MS Excel используется мастер функций (Вставка Функция…), в котором отображается имя функции, ее описание и аргументы.

Рисунок 1. Окно мастера функций

Первоначально следует создать таблицу основных логических операций:

Рисунок 2. Таблица истинности основных логических операций

Читать еще:  Как сделать ступенчатый график в excel?

При составлении таблицы истинности используются следующие формулы:

  1. Инверсия: =ЕСЛИ(A2=1;0;1);
  2. Дизъюнкция: =ЕСЛИ(ИЛИ(A2=1;B2=1);1;0);
  3. Конъюнкция: =ЕСЛИ(И(A2=1;B2=1);1;0);
  4. Импликация: =ЕСЛИ(И(A2=1;B2=0);0;1);
  5. Эквивалентность: =ЕСЛИ(A2=B2;1;0).

В последующей работе данная таблица может использоваться учащимися как основа для выполнения заданий лабораторной работы.

Учащимся может быть предложена следующая работа.

Задание: Построить таблицу истинности для формулы (A B C) A, используя MS Excel.

Алгоритм:

  1. Определить количество наборов входных переменных, по формуле: Q = 2 n , где n – количество переменных. Q = 2 3 = 8.
  2. Внести в таблицу все наборы входных переменных:

Рисунок 3. Исходные данные

  1. Определить количество логических операций и порядок их выполнения:
  • B
  • A B
  • A B C
  • (A B C) A
  1. Заполнить столбцы результатами выполнения логических операций в обозначенной последовательности.

Для этого в ячейку D2 ввести формулу: =ЕСЛИ(B2=1;0;1);

в E2: =ЕСЛИ(И(A2=1;D2=1);1;0);

в F2: =ЕСЛИ(И(E2=1;C2=0);0;1);

в G2: =ЕСЛИ(F2=A2;1;0).

Заполнение остальных строк произвести путем копирования введенной формулы.

Рисунок 4. Результат выполнения работы

Табличный процессор может быть использован для закрепления не только материала математической логики, но и для основ теории вероятностей и математической статистики.

Задачи для самостоятельного решения

Определить с помощью таблиц истинности равносильность формул.

Определить являются ли формулы тавтологиями.

Построение таблиц истинности в электронной таблице Excel. — презентация

Презентация была опубликована 6 лет назад пользователемschool.baltinform.ru

Похожие презентации

Презентация на тему: » Построение таблиц истинности в электронной таблице Excel.» — Транскрипт:

1 Построение таблиц истинности в электронной таблице Excel

2 Цели урока: обобщение и систематизация знаний по темам «Таблицы истинности», «Преобразование логических выражений», «Решение логических задач»; формирование умения автоматизировать решение логических задач в электронных таблицах MS Excel.

3 Проверка домашней работы: Круги Эйлера – Венна: 66, 67; Табличный способ решения логических задач: 59, 127.

4 Инверсия — логическое отрицание От лат. inversio — переворачиваю Логическое отрицание делает истинное высказывание ложным и, наоборот, ложное – истинным. AF=А Таблица истинности функции логического отрицания В переводе на естественный язык: «Не А» «Неверно, что А» ИСТИНА – 1 ЛОЖЬ — 0

5 Конъюнкция — логическое умножение От лат. conjunctio — связываю Результат логического умножения является истинным тогда и только тогда, когда истинны все входящие в него простые высказывания. Таблица истинности функции логического умножения ABF=A*B В переводе на естественный язык: «и А, и В» «как А, так и В» «А вместе с В» «А несмотря на В» «А, в то время как В» И,, and, &, *, ·

Читать еще:  Как сделать знак доллара в excel?

6 Дизъюнкция — логическое сложение От лат. disjunctio – различаю Результат логического сложения является истинным тогда, когда истинно хотя бы одно из входящих в него простых высказываний. В переводе на естественный язык: «А или В» Таблица истинности функции логического сложения ABF=A+B ИЛИ,, or, +

7 Импликация — логическое следование Результат логического следования является ложным тогда и только тогда, когда из истины следует ложь. От лат. implicatio – тесно связывать Таблица истинности функции логического следования ABF=A B А – условие, В – следствие, В переводе на естественный язык: «если А, то В» «В, если А» «Когда А, тогда В» «А достаточно для В» «А только тогда, когда В» «Для А необходимо, чтобы В»

8 Эквивалентность — логическое равенство Результат логического равенства является истинным тогда и только тогда, когда оба высказывания одновременно либо истинны, либо ложны. От лат. aeguivalens – равноценное Таблица истинности функции логического равенства ABF=A B В переводе на естественный язык: «А эквивалентно В» «А тогда и только тогда, когда В» =,,

9 В естественном языкеВ логике … и … … или … Неверно, что… … в том и только в том случае … … если …, то … … тогда и только тогда, когда … … не … Ниже приведена таблица, левая колонка которой содержит основные логические союзы (связки), с помощью которых в естественном языке строятся сложные высказывания. Заполните правую колонку таблицы соответствующими названиями логических операций.

10 В естественном языкеВ логике. и. конъюнкция. или. дизъюнкция Неверно, что. отрицание. хотя. конъюнкция. в том и только в том случае. эквивалентность. но. конъюнкция. а. конъюнкция Если. то. импликация. однако. конъюнкция. тогда и только тогда, когда. эквивалентность Либо. либо. строгая дизъюнкция. необходимо и достаточно. эквивалентность Из. следует. импликация. влечет. импликация. равносильно. эквивалентность. необходимо. импликация. достаточно. обратная импликация

11 Алгоритм построения таблицы истинности: 1.Подсчитать количество переменных n в логическом выражении; 2.Определить число строк в таблице, которое равно 2 n 3.Подсчитать количество логических операций в логическом выражении m и определить количество столбцов в таблице, которое равно m + n 4.Ввести названия столбцов таблицы в соответствии с последовательностью выполнения логических операций с учетом скобок и приоритетов; 5.Заполнить столбцы входных переменных наборами значений; 6.Провести заполнение таблицы истинности по столбцам, выполняя логические операции в соответствии с установленной в п.4 последовательностью.

Читать еще:  Как сделать общий доступ к файлу excel на гугл диске?

12 Построение таблиц истинности в электронной таблице Excel.

13 Как построить таблицу истинности в Microsoft Excel Алгоритм: 1.Установить по формуле последовательность выполнения логических операций; 2. Записать названия столбцов и возможные наборы значений исходных логических переменных; 3. Создать логические формулы: вставка — функция; выбрать категорию: логические; указать ячейки, в которых хранятся аргументы функции; протянуть формулу для всех значений логических переменных.

14 Составить таблицу истинности для логического выражения А & (В۷С).

15 АВСС(В ۷ С)А & (В ۷ С)

16 Составить таблицу истинности для логического выражения в тетради: F = (А۷В) & (А۷С) & (В&С) & А F = A & B v A & B F = A & (B & B C) F= A (B & C) F= (A & B) v (A & B) F= A & (B v B & C)

17 Домашняя работа: 1 ( 46). Обсуждая конструкцию нового трёхмоторного самолёта, трое конструкторов поочередно высказали следующие предположения: 1) при отказе второго двигателя надо приземляться, а при отказе третьего можно продолжать полёт; 2) при отказе первого двигателя лететь можно, или при отказе третьего двигателя лететь нельзя; 3) при отказе третьего двигателя лететь можно, но при отказе хотя бы одного из остальных надо садиться. Лётные испытания подтвердили правоту каждого из конструкторов. Определите, при отказе какого из двигателей нельзя продолжать полёт. 2 ( 54). Представим такую ситуацию: по телевизору синоптик объявляет прогноз погоды на завтра и утверждает следующее: 1. Если не будет ветра, то будет пасмурная погода без дождя. 2. Если будет дождь, то будет пасмурно и без ветра. 3. Если будет пасмурная погода, то будет дождь и не будет ветра. Так какая же погода будет завтра? Уровень знания: Записать условие задач 1 и 2 на языке алгебры логики. Разобрать решение задач в учебнике (п ) Уровень понимания: + Сформулировать достоинства и недостатки метода решения задач, основанного на алгебре логики. Уровень применения: + Сформулировать тип логических задач, решаемых данным методом.

Ссылка на основную публикацию
Adblock
detector